読者です 読者をやめる 読者になる 読者になる

Life goes on

何かJavaScriptとかVimとかMacとかに関係してそうな深淵から覗かれる者

gdbmがrequire出来ないの解消した。

Program

gdbmがrequireできない - Life goes on
前回のエントリでどうにもgdbmが読めないと書いたんですが、解決しました。

原因はportでgdbmを入れる前にrubyをインストールしてた事でした。考えれば当たり前ですね。恥かしい。

なので、一回rubyとrb-rubygemsをアンインストールしてから、再インストールしました。結構な数のgemを入れてたんで一応

gem list > gem.txt

として、後で分かるようにしてみましたが、結局意味は無かったです。

最初にrb-rubygemsからアンインストールしなきゃportに怒られるんで、こっちから。で、ruby1.8.7と1.9.1を両方アンインストールしてから再インストール。先日のスクリプトを実行したらエラー無しで実行できました。やったね、ママン。